No Posts for You!

I’m having problems posting so if you see this, I found a way around the problem. Which of the two problems, detailed below, I’m facing I can’t yet say.

It seems that the folks over at MySQL, the database that my web host uses, updated a module around July of last year. If your web host was efficient and updated the module, MovableType (MT), the content management system that I use, immediately refused to run many scripts that operate MT. One of those scripts is the one that publishes these posts. I don’t know if my web host, pair.com, just updated this module. If so, this may be the problem.

Throw into this mix, pair.com apparently throttles user scripts. That is, if one site is using a large portion of CPU cycles, pair will automatically and without warning kill the process. I can speculate that pair does this to avoid one site negatively affecting the operations of the others. I should note that pair, as does most other hosts, installs more than one website per server. In my case, there are about 150 sites running on a server using an Athlon XP2200+ with 1GB of RAM and a 120GB disk. For comparison, my wife’s 2.8GHz Intel P4 system is faster, has equal memory, and has a larger drive. This script throttling causes some MT operations to fall over because MT can use a lot of memory in rebuilding its pages.

So, I’m kind of stuck here. MT can’t post using its main script either because of the MySQL problem or because pair is killing the process that is used to rebuild this site (or something else is wrong).

Until I figure this out, my posts not make it. If that occurs, I will switch away from MT. To what, I don’t know yet although I am working on using plain HTML as a last resort.

Stay tuned.

Advertisements

Comments are closed.